Back to overview

DNS Resolution Issues - RESOLVED

Mar 12 at 11:27pm CET
Affected services
API
Admin Portal
Stories rendering engine
StorifyMe CDN
Website

Resolved
Mar 12 at 11:27pm CET

RESOLVED - Update 09:00 UTC: Issue has been resolved. Most users should now have access. DNS caches may take up to 24 hours to fully propagate.

What happened?
Between 03:00-09:00 UTC on March 11, we experienced intermittent DNS resolution issues due to a DNSSEC deployment timing window. Some DNS resolvers cached an intermediate configuration state, causing validation failures for a subset of users.

Current status:
- Issue fixed at 06:30 UTC
- Most users restored by 09:00 UTC
- Some ISP DNS caches may need up to 24 hours to refresh
- Expected complete: March 12, 06:30 UTC

Timeline:
03:00 UTC - DNSSEC deployment began
03:30 UTC - First customer reports
06:00 UTC - Root cause identified
06:30 UTC - Fix deployed
09:00 UTC - Most users restored

We apologize for any inconvenience and have implemented monitoring and process improvements to prevent similar issues.